Not logged inC1 Owners C1ub
Top Home Help Search Register Login OpenID
Up Topic Open C1ub Section / Open C1 Chat / Oil let came on and wouldn't go off!
- - By nickmiddy Date 01-07-2010 15:41 Edited 01-07-2010 15:45
Oil let came on and wouldn't go off on Tuesday!  So I checked the oil - all fine there.  Hmm, what could it be????  I searched the club and found a common fault is oil pressure switches.  SO, I decided I should order one up and replace it.  Ordered one up on Tuesday from  the fantastic new parts website and it arrived today.  So off out to the drive (after having checked my manual which I also got here) and whizzed out the old, popped in the new and hey, presto, no more oil light!

So, 15 minutes figuring out what it was on this site, 5 minutes ordering and paying, 10 minutes fitting and jobs a good 'un.  30 minutes all tolled - bet I would have paid for at least an hours labour at a BMW garage and over a tenner for the parts.  I paid a total of £3.50 for parts and shipping.

What a wonderful club this is!!!!
Parent - - By Monkeyrider Date 02-07-2013 20:20
Hi mate, I've got the same problem and just ordered a new pressure switch. Checked the Carl salter C1 repair manual but can't find where on the bike the switch is to remove. Any chance you could point me in the right direction? Can email me a pic if easier to michaelbriggs40@aol.com

Any help would be appreciated. Mike
Parent - By Clunkfish Date 02-07-2013 20:55

>Any chance you could point me in the right direction?


See attached photo :-)
Up Topic Open C1ub Section / Open C1 Chat / Oil let came on and wouldn't go off!

Powered by mwForum 2.29.3 © 1999-2013 Markus Wichitill